A Basic Dreamweaver 8 Project

BUILDING A TOWN WEBSITE 
Student Guide


In this project, you will learn the web publishing skills you need to

• Plan a website

• Define a website

• Create a basic town website

• Work with text and text formats

• Work with images and image rollovers

• Work with hyperlinks

• Check your site against accessibility standards

• Test your website for errors

• Manage your website
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Lesson 1: Setting up the Local Site and Root Folder
A website consists of folders containing files such as documents, images, and other media. When you create a website, you first need to establish the location of the website and all its related folders and files. 
In this lesson, you create the folder structure on your computer to store all the files for your website. You then use Dreamweaver 8 to define your local site and identify the root folder that will contain all the files for your site. (Note that before you can place your site on a web server, you first need to create it locally on your computer.)
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By creating and editing your pages on a local site on your computer before you copy the files to a web server, you can test your website to make sure it works properly before you make it available for public viewing. 
Every site is contained in a main folder, called the root folder. Most designers create subfolders inside the root folder to organise the site contents. The sample project site is organised with the site pages at the top level of the root folder. The root folder contains two subfolders—one for images and one for text files. 
To create the site folder structure: 

To set up a site similar to the sample Ledbury site illustrated in this project, create a root folder that will contain the web pages. Then create subfolders for images and text files. 

Create a root folder on the hard drive. Name it ledbury-site (or the name of your town). 
Note: Do not place your root folder within the Dreamweaver 8 application folder. If you ever need to reinstall Dreamweaver, you would lose your work. 
Create two subfolders in the root folder: one named images and the other named content.
Your folder structure should be similar to the figure below.

If you are creating the sample Ledbury website, copy the image files provided by your teacher into your images subfolder. Copy the text files into your content subfolder. 

When you create a larger website (ten or more pages), it is helpful to group each set of related pages in a separate subfolder inside the root folder. For example, if your site had several pages related to the history of your town, you could put them all in a subfolder named history. 


To define the website: 
The purpose of defining your website is to communicate to Dreamweaver the name and location of the root folder. 

Start Macromedia Dreamweaver 8. .
From the main bar at the top of the screen, choose Site > New Site. 

The Site Definition dialogue box opens. Click the Advanced tab. 

Note: If you click the Basic tab, Dreamweaver will lead you step by step through the complete process of defining a website, including the use of server technology.

From the Category list, select Local Info (if it’s not already selected). 
In the Site Name text box, type Ledbury or your own town, school, or class name. 
Beside the Local Root Folder box, click the Folder icon. Navigate to the location on the hard drive where you stored your root folder. 
Make sure you’re viewing the contents of the ledbury-site folder in the Choose Local Root Folder for Site Ledbury dialogue box. Then click Select (Windows) or Choose (Macintosh).



You return to the Site Definition dialogue box. Make sure Refresh Local File List Automatically and Enable Cache are checked.

If you know the URL your completed website will use, enter the information in the HTTP Address text box. Otherwise, you can add this information later, when you are ready to publish the site on a remote server.
 
Click OK to define your local site and folders. The “initial cache” message alerts you that the initial site cache is being created. Click OK.



Lesson 2: Creating the Home Page
In this lesson, you build the home page for your website. 
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There are many considerations when designing web pages. In this project, you focus on just the basic design elements needed to build this website. One basic element is the background colour of the pages. Adding colour to the background can add interest and help maintain the uniformity and identity of a site. Use caution, however, when selecting a background colour because the wrong combination of background and text colour can make your text difficult to read. 

To create a new document for the home page: 

Start Macromedia Dreamweaver 8. 
Choose File > New from the menu bar. 
In the New Document dialogue box, select Basic Page and click Create.

A new untitled Document window opens. 

To save the home page: 

Choose File > Save from the menu bar. 
The Save As dialogue box appears. It displays the folders in the site root folder. You will save the file in the root folder. 
Type index.htm (Windows) or index.html (Macintosh) in the Filename box. 
When you use the filename “index,” Dreamweaver automatically specifies that page as the home page. Then you don’t have to go through a separate step to specify the home page. 
Click Save. The filename now appears on the title bar of the Document window.



To set a page title for your document: 

In the Title text box (located in the Document tool bar), type Ledbury Home Page (or the name of your town). 
Press Enter (Windows) or Return (Macintosh). 

When this page is opened in a web browser, this title will appear on the title bar of the browser window. It is also the title used when the page is added to a browser’s Favourites (Microsoft Internet Explorer) or Bookmarks (Netscape Explorer) list. 

To change the background colour: 

From the menu bar, choose Modify > Page Properties to open the Page Properties dialogue box.

Experiment with the background colour. Click the Background Colour button (next to the Background label) to open the colour picker. The pointer changes to an eyedropper. 
As you select a colour, click Apply to preview how your selection will appear on the page. 
The sample project uses the default background colour (white), but feel free to choose another colour. 
When you are satisfied with the background colour, click OK to close the Page Properties dialogue box. 

Note: There are several ways to delete an element or action in Dreamweaver 8. You can use the Backspace and Delete keys. Alternatively, you can use the Edit commands: Cut, Clear, and Undo. The Undo command can undo the last 50 steps.


To insert text and hyperlinks: 

Position the insertion point at the top of the Document window. (Click in the Document window.) 
Type Ledbury (or the name of your town). Press Enter (Windows) or Return (Macintosh) to add a paragraph break. 
Select the text and change its formatting attributes by using the Property inspector. Experiment by clicking the format, size, colour button, font style, and alignment boxes.
Note: If the Property inspector isn’t open, choose Window > Properties from the menu bar. 
The sample Ledbury home page title has the following settings: 

• Format: Heading 1 
• Size: None 
• Colour: Dark red 
• Font style: Verdana, Arial, Helvetica 
• Alignment: Left-aligned 


Position the insertion point below the heading “Ledbury.” Add another paragraph break by pressing Enter (Windows) or Return (Macintosh). Then type Go to the Ledbury Net website. 
Select the words “Ledbury Net” (or the reference to a website related to your town). 
On the Property inspector, in the Link text box, type http://www.ledbury.net and press Enter (Windows) or Return (Macintosh). 
The hyperlink appears as underlined text on your web page. 
Any time you select text and add a URL in the Link text box, a hyperlink is created. Hyperlinks appear as underlined text on your web page. 
Add another paragraph break and type Go to the Ledbury Online website.
Select “Ledbury Online” and type http://www.LedburyOnline.co.uk/index.html in the Link text box


 If you want to make text smaller, select the text and change the size to a number such as –1. 



To insert images: 

1. Position the insertion point below the heading “Ledbury.” 
2. Open the folder ‘Images’ from the right and side of the screen and drag the image ‘ledbury_market_house.jpg’, you will be asked to enter an alternative text, enter Ledbury Market House photograph



4. Position the insertion point to the right of the image and add a smaller paragraph break by pressing Shift+Enter (Windows) or Shift+Return (Macintosh). 
5. Under the image, type a caption such as Ledbury’s historic Market House.
To insert an e-mail link: 

You can insert an e-mail link to an important office such as your town or neighbourhood council. 
Position the insertion point at the end of “Go to the Ledbury Online website” and add a paragraph break by pressing Enter (Windows) or Return (Macintosh).


The insertion point should be on the line below “Go to the Ledbury Online website.” 

On the Common tab of the Insert bar, click Email Link (the envelope button). In the Text box, type Send email to the Ledbury Town Council. In the Email text box, type someone@ledburycouncil.gov.uk.

Click OK. 
Your page should look something like the one below.



To place text in a specific area (insert a layer): 

You may want to place text in a very specific area of the page. One of the ways you can do this is to insert a layer. A layer is a container for HTML content (such as text and images) that you can position anywhere on a page. Layers can contain text, images, forms, plug-in objects, and even other layers. Any element you can place in the body of an HTML document you can also place on a layer. 

Click the Layout tab on the Insert bar. 
In the Layout category, click the Standard View button (if necessary). 
To switch to the Common category, click the Common tab. R
Click Draw Layer (fifth button from the left) and position the pointer in the Document window.

The pointer changes to crosshairs, indicating that drag-and-draw is in effect. 
Position the crosshairs near the top right corner of the image and drag to draw a box beside the image 75 or 100 cm wide by about 75cm tall. 
Note: The layer outline may look like it has moved up above the image. Don’t worry. It will be aligned with the top of the image when viewed in a web browser. 
Click inside the layer to position the insertion point on the layer. Enter the following information about Ledbury (or similar information about your town). Press Enter (Windows) or Return (Macintosh) at the end of each item. 
County: Herefordshire Population: 7,350 Mayor: Phil Bettington Schools: Ledbury Primary School and The John Masefield High School Newspaper: Ledbury Reporter 
Using the Property inspector, change the text style, size, colour, and alignment as you prefer. 
Your page should look like the figure below.

Note: If you press Enter (Windows) or Return (Macintosh), you create a paragraph break. When you want less space to appear between lines of text but want text to appear on separate lines, use a line break. To insert a line break, hold down the Shift key on your keyboard as you press Enter (Windows) or Return (Macintosh). 


To preview the home page: 

Choose File > Save from the menu bar. 
From the menu bar, choose File > Preview in Browser and then choose the browser you want to use to preview your newly created web page. 

[image: ]

Test the link and the e-mail sender. (Don’t actually send an e-mail message. Just make sure the e-mail sender opens when you click the e-mail link.) 
Close the browser window. 
Close the home page. 


Lesson 3: Creating the Other Web Pages
In this lesson, you create the History, Directory, Events, and Map pages for your website. 
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It is very easy to include previously created text on web pages. You do not need to retype information from documents you already have. All you need to use are the Copy and Paste commands. 
First, create a new Document window in which you will build the History page. 

In Dreamweaver 8, choose File > New from the menu bar. 
In the New Document dialogue box, select Basic Page and click Create. 
A new untitled Document window opens. 

To save the History page: 

You should save your work on a page as you build it, but always save a page when you are ready to work on another page. 
Add a title to this page. On the Document toolbar, select Untitled Document in the Title text box and type a title such as Ledbury History. 
Make any other changes to the page properties according to your design plan. 
From the menu bar, choose File > Save. 
Navigate to the root folder. 
Type history.htm (Windows) or history.html (Macintosh) in the Filename text box. 
Click Save. 

To incorporate previously created text: 

Drag the file ‘history.doc’ from the content folder onto the page.
The following window will appear.
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Select OK without making any changes.

Note: You may need to adjust line breaks and paragraph breaks in the text you’ve pasted. For example, if there is no space between paragraphs, that means the paragraph breaks from the text file have been replaced with line breaks in Dreamweaver. You can position the insertion point at the beginning of a paragraph, press Delete or Backspace to remove the line break, then press Enter (Windows) or Return (Macintosh) to insert a paragraph break. 
Use the Property inspector to change the text attributes of the page title, so it matches the format of the title on the home page. 
Change text attributes of the paragraphs so the page is well-organised and readable. 
Note: The text-editing commands in Dreamweaver MX are similar to those in word processors. You can access these commands from the Edit menu or by using the keyboard commands listed here. 
	Command 
	Windows 
	Macintosh 

	Copy 
	Ctrl+C 
	Command+C 

	Cut 
	Ctrl+X 
	Command+X 

	Paste 
	Ctrl+V 
	Command+V 

	Clear 
	Delete/Backspace 
	Delete/Backspace 



To create an unordered bulleted list: 

Lists are usually easier to read and understand if they are set off from the surrounding text. In Dreamweaver MX you can create three types of lists: 

• An unordered list (with square, round, or no bullets) 
• An ordered list (with numbers, letters, or roman numerals) 
• A definition list (in which the first line is a term or phrase and the second line is indented) 

Position the insertion point at the end of the last text line and press Enter (Windows) or Return (Macintosh) to insert a paragraph break. 
Select the paragraphs of the list to which you want to add bullets—in the Ledbury history sample, the historic sites listed at the bottom of the page.

On the Property inspector, click Unordered List (bullets button) or choose Text > List > Unordered List from the menu bar. 
The paragraphs in the list are indented and set off with bullets.
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To add hyperlinks: 
A simple way to link your web page to information on other websites is to change one word or a phrase into a hyperlink. A hyperlink is text or a graphic that links to a different web page or to another section of the same page. 
Select the words “Eastnor Castle” in the list of historic sites.
 On the Property inspector, type http://www.eastnorcastle.co.uk in the Link text box. 

Note: When you enter URLs in the Link text box, you must include “http://” for the link to work. 
The hyperlinked text appears underlined on the page. 

[image: ]

To preview the History page: 

Save the History page. 
To preview your work in a browser, click Preview/Debug in Browser (globe button) on the Document toolbar. Select the browser you want to use to preview the web page. 
Close the browser window and then close the History Document window.
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You can use tables to lay out columns and rows of data, text, and graphics. Once you create a table, you can easily modify its structure and how it looks. On this web page, you use a table to communicate contact information for local organisations. 
First, create a new Document window in which you will build the Directory page. 
In Dreamweaver MX, choose File > New from the menu bar. 
In the New Document dialogue box, select Basic Page and click Create. 
A new untitled Document window opens. 

To save the Directory page: 

You should save your work on a page as you build it, but always save a page when you are ready to create another page. 
Add a title to this page. On the Document toolbar, type a title such as Ledbury Directory in the Title text box. 
Make any other changes to the page properties according to your design plan. 
From the menu bar, choose File > Save. 
Select OK. 
Type directory.htm (Windows) or directory.html (Macintosh) in the Filename text box. 
Click Save.


To add a table: 
Type a heading for the new page. Press Enter (Windows) or Return (Macintosh) twice to add a couple of paragraph breaks before you format the heading. 
Select the heading on the first line and format it by using the Property inspector 
Position the insertion point below the page heading. In the Common category on the Insert bar, click Insert Table. 
The Insert Table dialogue box opens. 
Set Rows to 15, Columns to 3, Width to 500 Pixels, and Border to 1. 

The default settings for the rest of the table attributes are fine.

Click OK. 
A 15-row by 3-column table is added to the page. The table is surrounded by handles, indicating that the table is selected. (If it is not selected, click within the table and choose Modify > Table > Select Table from the menu bar) 
Click in the first cell of the table. 
The Property inspector changes to reflect the attributes of the cell. 
To see more of the cell properties, expand the Property inspector if necessary by clicking the expander arrow in the lower right corner of the inspector. 
Tables in Dreamweaver MX use commands similar to those in word processors. You can add and delete rows; split and merge cells; and modify cell, row, and column properties. 
Type the following sample data in the table, or type information from your own town. To move from one cell to the next, press the Tab key or click in a cell.


Normally, the first row or column in a table is the heading information. Select the first row of the table by positioning the mouse pointer on the left border of the first cell in the first row until it changes to a right pointing arrow. Click the border and the first row of cells is highlighted. 
On the Property inspector, for Format, select Heading 5.
This boldfaces the entire row of text.



Experiment with different text sizes for the rest of the table. Make sure all the text is readable. 
Try changing the alignment of the text within each cell. Experiment by using the alignment buttons. 
Experiment changing border and background colours by using the Bdr Color and Bg Color buttons on the lower part of the Property inspector. For example, you could use different colours to show related information in the table. 
Although you can get carried away and embellish your text so much that it detracts from the content, visual organisation is important for effective communication. 
Use the following suggestions to enhance the presentation of the information: 

• 	Select text and add hyperlink information to enable navigation to an organisation’s web page. For the Ledbury sample project you could add the following: 

West Mercia Constabulary: http://www.westmercia.police.uk 
The John Masefield High School: http://www.johnmaserfield.hereford.sch.uk 
Crimestoppers: http://www.westmercia.police.uk/crimestoppers/default.htm 
Community Voluntary Action Ledbury: http://www.voluntaryactionledbury.org.uk 

• Insert a column for organisation photographs and add an image of an organisation. 



To preview the Directory page: 

Save the Directory page.
Preview your work in a browser. 
Close the browser window and then close the Directory Document window. 

[bookmark: _Toc171236020]BUILDING THE EVENTS PAGE 

The events page contains information about recurring events in the community. Many formats are possible for an events calendar. For example, it can be displayed in tabular form (as a table) similar to a wall calendar. For the events calendar on this page, you use a list that highlights only important months. 
1. Create a new page in Dreamweaver MX. Choose File > New. 
The New Document dialogue box appears. The Basic Page category is displayed and the HTML page type is selected. That’s what you want. 
2. Click Create. 
A new Document window opens. 

To save the Events page: 

You should save your work on a page as you build it, but always save a page when you are ready to create another page. 

Create a title for this page. On the Document toolbar, type a title such as Ledbury Events in the Title text box. 
Make any other changes to the page properties according to your design plan. 
From the menu bar, choose File > Save. 
Type events.htm (Windows) or events.html (Macintosh) in the Filename text box. 
Click Save. 



To add text from a text file: 

Drag the file ‘events.txt’ onto the page like you did on the previous page ‘History’ and click OK from the dialogue box.
Format the heading for this page, Ledbury Events, as you have done on the other pages.
To make the list more readable, add bullets to the list items under each subheading, as shown in the following figure.



To add a bullet to a paragraph, position the insertion point in the paragraph and either click Unordered List on the Property inspector or choose Text > List > Unordered List from the menu bar. 
You can change some of the default properties of unordered and ordered lists. For example, after you have created an unordered list, suppose you decide you want square bullets. To change from the default round bullets to square bullets, click any line in the list and choose Text > List > Properties to open the List Properties dialogue box. Change to the desired style of bullets. 
You can enhance the presentation of the information by adding hyperlinks that will give viewers additional information. For example, the Ledbury Poetry Festival is hyperlinked on the sample Events page; the address of the Festival’s website is http://www.poetry-festival.com. 
Save the Events page. 
Test the Events page in a browser. 
Close the browser window and close the Events Document window.


[bookmark: _Toc171236021]BUILDING THE MAP PAGE

Maps and driving directions to the town are really helpful to first-time visitors. You can present this information in a variety ways. In this lesson, you use an image rollover to create the information on this page. 

Create a new page. Choose File > New. 
The New Document dialogue box appears. The Basic Page category is displayed, and the HTML page type is selected. That’s what you want. 
Click Create. 
A new Document window opens. 


To save the Map page: 

You should save your work on a page as you build it, but always save a page when you are ready to create another page. 

To create a title for this page, type a title such as Ledbury Map and Driving Directions in the Title text box. 
Make any other changes to the page properties according to your design plan. 
From the menu bar, choose File > Save. 
Type map.htm (Windows) or map.html (Macintosh) in the Filename text box. 
Click Save. 

To create a rollover: 
A rollover is an image that changes when the pointer moves over it. A rollover consists of two images: the original, or primary, image (displayed when the page is first loaded), and the rollover image (displayed when the pointer moves over the primary image). Creating an image rollover is simple. First pick two images you want to use. For this example, for the Ledbury map, you can use map_herefordshire.gif and map_ledbury.gif. 

Type a heading such as Ledbury Map and Driving Directions at the top of the page. 
In the Common category on the Insert bar, click Rollover Image. 
The Insert Rollover Image dialogue box appears. 



In the Image Name text box, type Area Map. 
Use the Browse buttons beside the Original Image and Rollover Image text boxes to navigate to the images subfolder in the root folder. Select the original image, such as map_herefordshire.gif. Select the rollover image, such as map_ledbury.gif. 
Check the Preload Rollover Image box to have Dreamweaver MX preload the image in the browser’s cache memory.
In the Alternate Text box, type a short description of your images, such as Map of Herefordshire and Ledbury Town Centre. 
You can add a hyperlink if you like. For this sample project, you can leave the When Clicked, Go to URL text box blank. 
The Insert Rollover Image dialogue box should look like the following figure.
Click OK. 
The rollover image is inserted on the page. 


If you would like to add a border to the image, select the image and type a number in the Border text box on the Property inspector.



To test the rollover: 

Save the Map page.
Choose File > Preview in Browser and then choose the browser you want to use to preview the page. 
In the browser, move the pointer over the primary image. 
The display should switch to the rollover image. 
Close the browser window. 

To add driving directions and other information: 

Use the text-editing techniques described in previous steps to add information to the page. Here are some suggestions: 

• Insert a layer or table to place information in a specific area. 
• Use an ordered list to indicate the directions to the town. 
• Add hyperlinks to text. 
• Add other town images. 

For example, the directions to Ledbury are as follows: 

From Hereford: Drive east on the A438 to Ledbury. 
From Leominster: Drive south on the A417 to Ledbury. 
From Ross on Wye: Drive north on the A449 to Ledbury. 
From Gloucester: Drive north on the A417 to Ledbury. 
From London: Take the M4 to Swindon, drive north on the A419 to Cirencester, then drive north on the A417 to Ledbury. 


The figure below shows the directions placed in a layer beside the image.



Lesson 4: Connecting the Web Pages

In this lesson, you will create a table on the home page to provide the navigation links between the pages of your website. Then you will use that table as a template to copy to the other pages. You will then modify each page to ensure that you have the appropriate links. 

To create a navigation table: 

Open the home page (index.htm) in Dreamweaver 8. Choose File > Open, and double-click the filename index.htm. 
Position the insertion point at the bottom of the page. 
In the Common category on the Insert bar, click Insert Table. 
Create a table with 1 row, 5 columns, a width of 97%, and no border. 
Click inside the table and choose Modify > Table > Select Table from the menu bar. 
On the Property inspector, select Centre from the Align pop-up menu to centre the table at the bottom of the page. 
Move the pointer to the left edge of the table. Click when the pointer changes into an arrow pointing to the right. 
The whole row of cells is selected. 
On the Property inspector, click the Align Center button (in the upper right part of the Property inspector). 

Now anything you put in a cell will be centred in the cell. 



To insert a Macromedia Flash button: 

All the buttons needed for the web site are in the ‘Flash’ folder, you will need to drag each button into the appropriate section of the table.

[image: ]

When you have created the table and inserted all the buttons, test they work and then copy this and paste on all you other pages.

If you are able to create your own buttons and you know how to hyperlink them then you can chose a  suitable button.
Ledbury Web Site	Page 23
image13.emf

image14.png
Insert Document

How would you ke to nsert the doaument?
© nsert e contentsl
O Textonly
© Textwith structure (paragraphs, ists, tabes, etc)
© Textwith structure plus basc formating (old, tac)
O Text with structure pius ful formatting (bold, taiic, styles)
‘Clean up Word paragraph spacing
O createalnk

Cre ] o J[Ceme )




image16.emf

image17.emf

image25.png
D

[ vesern| Te: =
[, [, L L

Worcester Bminghan From Hereford:

Drive cast on the A438 to Ledbury.
From Leominster:
Drive south on the A417 to Ledbury.
From Ross on Wye:
Drive north on the A449 to Ledbury.
From Gloucester:
Drive north on the A417 to Ledbury.
Swindon@  From Londo

Take the M4 to Swindon, drive north on the A419 to
Cirencester, then drive north on the A417 to Ledbury.

062 ‘

(A NG WIS M

<

1203x 561+ 6/ 1sec.

& Ledbury | [Localvien v

el ey a|R

EID _Ste -Ledbury (N:\DDalpreamme
2@ content

6] lechay_marethouse .
1) mapherefocshre of
) mapiedburyof
arectary utton.ut
Drectory.hin
cventebuton snf
vt ind

try button.suf
vty i

home buton snf
Jaiyes

Hep Button.sut

Map i

. >
Tioca tems selected tota (Log..)




